Skip to main content

News

  • New version of Geooh Live published!

Topic: Getting location... (Read 38 times) previous topic - next topic

Getting location...
first off, i don't have enough info to say this is repeatable but this is what happened.

out in the country. cell signal looked ok but who knows about data. i wanted to call up a specific cache for more information (more logs). i went to search and entered in the gc code (my search is the minimal search screen). i clicked search and it just sat there with a box that said Getting location...
after a while it stopped and i was back at the main menu.
tried same search again, same result.
went back to looking for the cache. started raining, headed to the car, tried again this time using the @Live . it wasn't really close to where i was but a short scroll of the map and a refresh and the cache was there and i brought it up.

now i'm home and i can bring up that cache using the search no problem but the data is good around here.

perhaps there was some trouble with the phone and the location services, but i wondered why the search even needed to determine my location when i was just calling up specific cache info.

anyways, just wanted to put it out there. maybe there's a problem, maybe it was just circumstances.


Re: Getting location...
Reply #1
Geooh was trying to determine your location before the search... which most of the time would involve your location... but you are correct in that it's not needed when searching by gc code. I've updated Geooh to exclude the location search when there are gc codes being used.

It also highlights that Geooh should be checking for network connectivity before even attempting a search. If it had, you may have gotten a warning and no attempt to get a location or search would be performed. That has been corrected also.

Thanks for bringing this to my attention!