Skip to main content


  • New version of Geooh Live published!

Topic: Weird behavior when correcting coordinates (Read 98 times) previous topic - next topic

Weird behavior when correcting coordinates
I wanted to test corrected coordinates to see how it worked in this app so I changed the coordinates on a random cache just to see how it worked. It turns out that I entered the coordinates in a format that wasn't acceptable (see below) so I got an error message about that. Then I tried again, but using the method of clicking on the map to set the new coordinates (neat!). This gave me an error message about that a cache can't have more than one corrected coordinates record. Well, no. I'd expect the app to update the one there is. On the other hand, in this case I didn't expect there to be one to begin with since I got an error message on my first try. Still, checking on the web site, the corrected coordinates are set according to my second attempt even though an error was reported.

The coordinate format that wasn't acceptable was "n58 12.345 e015 34.567" which is, to my mind, very standard and as far as I know accepted everywhere else. It would help a lot with cutting and pasting from other sources if that was accepted here as well.

Re: Weird behavior when correcting coordinates
Reply #1
Thanks for the information... there are two issues here:

1) The message about not having more than one corrected coordinates comes from Groundspeak, not Geooh. Unfortunately they don't accept requests from apps to add corrected coordinates if one already exists. They intend for you to delete the corrected one first before submitting another. I'm reluctant to have Geooh automatically delete the previous in case it's not what was intended. The safest path is for someone to explicitly delete before add a corrected waypoint again.

2) The "n58 12.345 e015 34.567" format is one that Geooh accepts, but it didn't have a comma ',' between the lat/lon components so it wasn't accepted. A fix was added to Geooh to attempt to parse out the values and insert a comma on it's own so things should work now even if you don't supply a comma. Expect this in the next Geooh release.

BTW, you can also long-press on the field to open up a widget with scrollable wheels to enter values. Geooh gives you 3 options: 1) use the map reticle widget (yes, it is neat), 2) use the wheel widget, or 3) enter numbers directly into the field.

Thanks again for taking the time to provide feedback here!

Re: Weird behavior when correcting coordinates
Reply #2
I haven't seen anyone else requiring a comma in that format, but great if the app will start to handle coordinates without it.

As for 1), would it be possible to have a better error message, perhaps even with a "Delete and rewrite?" button?

Re: Weird behavior when correcting coordinates
Reply #3
The message is Groundspeak's... Geooh is just displaying it. We'll see if it can be changed on the fly to a better response.