Skip to main content

News

  • New version of Geooh Live published!

Topic: Field Notes (Read 82 times) previous topic - next topic

Field Notes
Ron,

After taking a break from caching I've decided to get back into it.  I've always had your app installed and updated on my phone and it's icon has a spot on the center of my home screen.  :D

I'm wanting to use the field notes to log my caches but can't figure out how it works.  Here's my goal:

1. Find a cache (right now the hardest part)
2. Log the find in Geooh to a field note which I can then load into GSAK
3. Load the field note into GSAK for editing and posting to gc.com

In the Logs section of settings, I have set the path for the Drafts File and can see that a 0kb file is created.  But when I log a cache via the Create a Draft option, the field notes file does not get updated.  I've tried using three different folders.  One on the phone storage, one on the SD card, and one to my Google Drive.  I'd really really like to use the Google Drive folder b/c this would be sync'd up all the time and make the import into GSAK very easy.

What am I missing?

Re: Field Notes
Reply #1
Hi Paul,

Great you are getting back into caching. So the drafts file specified in Settings was created and accessible... even to other text editors? When saving the draft do you get a message at the bottom of the screen saying the draft was successfully written?

My testing indicates it should be working, but given all the different Android devices and versions there could be something Geooh wasn't ready for. I did discovered some issues with Google Drive so I've updated the code for the next maintenance release, but more messages if something didn't write properly.

Sounds like you are doing what should be done. In another week, I'll push out the new maintenance release which would send me a bug report is something isn't working right. You may have to wait until them... or store the drafts on the server. Sorry.

Re: Field Notes
Reply #2
Soooo....yeah....turns out that part of the issue was me.  >:( Part of the issue may be the app.  Mostly it was me.

When I have Geooh set to save the file to phone or SD card, the file is updated when I tap on SUBMIT.  I was clicking on Save for Later thinking that the Submit option was actually logging the cache to GC.com.  That part is on me.  I can then run the app FolderSync to upload the file to my Google Drive where I can access it via GSAK.

When I have Geooh set to save the file to my Google Drive I get the following error when I tap Submit: Problem writing the draft: java.io.FileNotFoundException: Unsupported mode:wa

Another problem that I came across occurs AFTER I have pulled the file into GSAK.  Once the file is imported into GSAK, it is deleted from the PC.  When FolderSync runs again, it syncs the deletion back to the phone.  Now when I go to Create a Draft and tap Submit, I get a pretty log and nasty error message.  I'm pretty sure that the message really means "file not found".  I then have to go into Settings and do the Create function again.  I'm working on getting my GSAK macro to copy a blanknotes.txt to FieldNotes.txt now to see if that will serve as a workaround for the error.

Is there a way that Geooh could create the file if it doesn't exist? 


Re: Field Notes
Reply #3
It doesn't look like the copy file option will work.  Even when I restore a copy of the drafts file that Geooh created back to the original name, Geooh throws up an error.

For the time being, I'm going to set GSAK to NOT delete the Drafts file after importing.  I'll use the setting "Ignore logs on or before".  The downside to this is that if I make a find in the morning and log it via GSAK and then make a find in the afternoon, GSAK will ignore the log on the second import since it's set to ignore log on the same date.  I kinda with that setting was just for logs BEFORE the date set.  I don't think this will be a big deal since I rarely have the time to make multiple caches in the same day.  Even if I do I'll probably log them all at night.

Re: Field Notes
Reply #4
What was the error message when the restore a copy was used? The "unsupported mode: wa" is fixed in the next release.

I'll see what can be done to create the file... sometimes Android is so screwy related to permissions and the file access technique used that it's a struggle to do simple things. For example, Google Drive really wants security so that apps just can't create things on their own... so there is a hand-off to Android to prompt the user for the file creation... so an app can't create without the user knowing it. It's messy, but more secure in a way.

Re: Field Notes
Reply #5
I'll do some more testing on what the message is when the fieldnotes.txt file is not on the device.  It's a rather long message, so I'll take a screen shot of it and post it here.

I don't necessarily need to use Google Drive with Geooh to store the file.  I'm fine with it being on the device (phone or SD card storage).  I use FolderSync to sync other files from other apps and will be fine using it with Geooh.  If it could just create a new file locally if it doesn't exist then that would be great.

Re: Field Notes
Reply #6
I am attaching a pic of my setting and of the error I now get when restoring a known good FieldNotes.txt file.  The message that I get today is not the same that I got the other day.  The new one is pretty user friendly.  :))

Re: Field Notes
Reply #7
Yeah, that's all good for the most part. Unfortunately, the way Android works with "content://" type files (which means they can be any cloud file) requires the file to be created outside of Geooh. I could not find a way to create it... I could only write to it. That's why there is a Create button when selecting where drafts go.

For now don't let your transfer method delete the file... or you'll have to recreate it. Or try to use SD storage for the draft file (which should have a "file://" type prefix I believe. It's not the best solution, but sometimes neither is Android.

Re: Field Notes
Reply #8
Hmmm...it seems that no matter where I save the file it's set to content:// . I've tried phone storage, SD card, and Google Drive (expected here though).

I've also noticed that when I go to set the path/file name, if I choose Pick (instead of create) and then pick the .txt file that I get the "There was a problem writing the draft.  Does the drafts file specified in Settings exist?" message.  If I choose Create and then select a file that exists, I get an overwrite prompt.  When I tap yes to overwrite everything works fine AND it doesn't overwrite the file.
  • Last Edit: October 18, 2018, 03:34:39 PM by pkelsay

Re: Field Notes
Reply #9
Well, that must just be the new way then in order to allow cloud storage.