Skip to main content

News

  • New version of Geooh Live published!

Topic: Brown circles on map, using Mapsforge offline maps (Read 59 times) previous topic - next topic

Brown circles on map, using Mapsforge offline maps
Hi

Ran into this the other day, and I'm not sure what it means.  I'll get brown circles over portions of the map when using offline maps.  In the attached image, there is one circle, but there can be multiple, and they can be in different places, though they don't move as I use the app (once they're drawn, they seem to persist through zooming and such).

Do the circles have a meaning?

Re: Brown circles on map, using Mapsforge offline maps
Reply #1
Hi, it looks you may have turned on Show Geocache Radius in Settings. Showing the radius is typically used by someone wanting to place a cache so they can be sure they are not too near another one which Groundspeak will restrict when too close. See the attached screenshot of the setting.

But oddly, some caches are not showing a radius... and it appears those may be stacked together in the darker brown circle. That's a bug I need to look into. Please check your settings and see if you have Show Geocache Radius turned on then let me know if it cleared things up after unchecking it.

Re: Brown circles on map, using Mapsforge offline maps
Reply #2
Hi

I do have that feature turned on, and turning that off does clear up the issue.

With the 161m radius turned back on, I also turned off "Cluster Map Markers", and I'm not seeing the issue yet ..  Perhaps related?

It seems that I can get the issue to re-appear if I switch back and forth between small sets of cache lists - open a list of caches, and centre on the caches, zoom in/out.  Back out, select a different list, centre on the caches, and it'll usually happen.

Re: Brown circles on map, using Mapsforge offline maps
Reply #3
Thanks for the feedback.

Ahhh, having clustering on could confuse things... will check that out. Does the issue only show with clustering? Or does it show only when switching lists?

Re: Brown circles on map, using Mapsforge offline maps
Reply #4
Sorry for the confusion .. 

I can't reliably make the solid brown circles show up.  Switching lists seems to encourage them to show up.  Even loading "@live" has the circles generally appear, but not 100% of the time.  Sometimes the display is completely correct.

The issue seems to depend on clustering.  Just testing now, 5/5 times loading a list with clustering enabled, the solid circles appeared.  With clustering disabled, on 5 loads, no circles appear.

Cluster size doesn't seem to have a bearing on things:
- Set the initial zoom to be 12 (instead of the default 13)
- Change the minimum cluster size to 20
- Open "@Live" list
- Zoom in one level
seems to be reliably producing the issue (so far...)

However, if the display isn't clustered to begin with, I don't see the issue:
- Leave the initial zoom to be 13
- Change the minimum cluster size to 20
- open "@Live" list (no clusters are shown)
- Zoom in / out, effect does not show up.

But, continuing to mess around...
- If I am zoomed out (12 or 11, I'm not actually certain at this point), drag the map to a different area in the city, refresh, I get clusters
- Zoom in, I get brown circles

Seems to be related to if clusters are initially drawn, instead of drawn after the caches are all loaded?

Let me know what else I can test for you.

Thanks!
  • Last Edit: September 03, 2018, 09:48:36 AM by timatlee

Re: Brown circles on map, using Mapsforge offline maps
Reply #5
Thanks for the detailed analysis. I was able to replicate some of the issue by following your scenarios. Providing a reliable fix was just not working well though given the nature of clustering so for now I've disabled showing radiuses whenever clustering is on. Probably best anyway because with clustering and radiuses both on something may not be drawn as intended. This change will be in the next release.